$re = '/(?<!\S)pattern(?!\S)(?=(?:(?!(?<!\S)(?:start|end)(?!\S)).)*?(?<!\S)end(?!\S))/m';
$str = 'pattern foo start fkdsjflsd pattern jdflsdjf pattern end';
$subst = "replace_pattern";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;