import Foundation
let pattern = #"(?<!\S)pattern(?!\S)(?=(?:(?!(?<!\S)(?:start|end)(?!\S)).)*?(?<!\S)end(?!\S))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"pattern foo start fkdsjflsd pattern jdflsdjf pattern end"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"replace_pattern"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)