using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"user-type=\s+:(\w+)!.*:([\S\s]+)";
string input = @"badges: @badges=;color=;display-name=;emotes=;message-id=34;thread-id=5575526_123681740;turbo=0;user-id=5575526;user-type= :teonnyn!teonnyn@teonnyn.tmi.twitch.tv WHISPER blastweb :Hello Bot";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}