package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`user-type=\s+:(\w+)!.*:([\S\s]+)`)
var str = `badges: @badges=;color=;display-name=;emotes=;message-id=34;thread-id=5575526_123681740;turbo=0;user-id=5575526;user-type= :teonnyn!teonnyn@teonnyn.tmi.twitch.tv WHISPER blastweb :Hello Bot`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}