import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{4}-\\d{2}-\\d{2}T\\d{2}:\\d{2}:\\d{2})(Z|[\\+-]\\d{2}:?\\d{2})?$";
final String string = "Should match ISO 8601 datetime for Forecast.io API:\n"
+ "[YYYY]-[MM]-[DD]T[HH]:[MM]:[SS]\n"
+ "with an optional time zone formatted as Z for GMT time or {+,-}[HH][MM] (with or without separating colon) for an offset\n\n"
+ "Should Match:\n"
+ "2008-09-15T15:53:00\n"
+ "2007-03-01T13:00:00Z\n"
+ "2015-10-05T21:46:54-0800\n"
+ "2015-10-05T21:46:54+00:00\n\n"
+ "Should Not Match:\n"
+ "2008\n"
+ "2008-09\n"
+ "2008-09-15\n"
+ "2008-09-15 11:12:13\n"
+ "2008-09-15 11:12\n"
+ "1988-05-26T23:00:00.000Z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}