# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2})(Z|[\+-]\d{2}:?\d{2})?$"
test_str = ("Should match ISO 8601 datetime for Forecast.io API:\n"
"[YYYY]-[MM]-[DD]T[HH]:[MM]:[SS]\n"
"with an optional time zone formatted as Z for GMT time or {+,-}[HH][MM] (with or without separating colon) for an offset\n\n"
"Should Match:\n"
"2008-09-15T15:53:00\n"
"2007-03-01T13:00:00Z\n"
"2015-10-05T21:46:54-0800\n"
"2015-10-05T21:46:54+00:00\n\n"
"Should Not Match:\n"
"2008\n"
"2008-09\n"
"2008-09-15\n"
"2008-09-15 11:12:13\n"
"2008-09-15 11:12\n"
"1988-05-26T23:00:00.000Z")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.