re = /^(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2})(Z|[\+-]\d{2}:?\d{2})?$/m
str = 'Should match ISO 8601 datetime for Forecast.io API:
[YYYY]-[MM]-[DD]T[HH]:[MM]:[SS]
with an optional time zone formatted as Z for GMT time or {+,-}[HH][MM] (with or without separating colon) for an offset
Should Match:
2008-09-15T15:53:00
2007-03-01T13:00:00Z
2015-10-05T21:46:54-0800
2015-10-05T21:46:54+00:00
Should Not Match:
2008
2008-09
2008-09-15
2008-09-15 11:12:13
2008-09-15 11:12
1988-05-26T23:00:00.000Z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end