#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^\s*#include\s*"|\G)[^\\"]*\K\\"
Local $sString = "#include "...\...\foo\bar.c" /* Here */// a \comment\ /\/ "foo\bar""
Local $sSubst = "/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)