$re = '/(?:^\s*#include\s*"|\G)[^\\\\"]*\K\\\\/m';
$str = '#include "...\\...\\foo\\bar.c" /* Here */// a \\comment\\ /\\/ "foo\\bar"';
$subst = "/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;