const regex = /(?:^\s*#include\s*"|\G)[^\\"]*\K\\/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\s*#include\\s*"|\\G)[^\\\\"]*\\K\\\\', 'gm')
const str = `#include "...\\...\\foo\\bar.c" /* Here */// a \\comment\\ /\\/ "foo\\bar"`;
const subst = `/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);