using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{12}\KTest(?!(?:added|deleted)\b).*$";
string input = @"1234567890ABTest
ABC4567890ABTestadded
ABC4567890ABTest2";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}