re = /^.{12}\KTest(?!(?:added|deleted)\b).*$/mi
str = '1234567890ABTest
ABC4567890ABTestadded
ABC4567890ABTest2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end