package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\bdownload\b(.*?)\bmusic\b`)
var str = `trying to download some music, give me the details to download the music`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}