$re = '/\bdownload\b(.*?)\bmusic\b/i';
$str = 'trying to download some music, give me the details to download the music';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);