re = /\bdownload\b(.*?)\bmusic\b/i
str = 'trying to download some music, give me the details to download the music'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end