const regex = /\s(\S*)\sinstagram|www\.instagram\.com\/([^\/\s]*)\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(\\S*)\\sinstagram|www\\.instagram\\.com\\\/([^\\\/\\s]*)\\\/', 'gm')
const str = `Из текста Julia julia_abramova_ instagram нужно вытащить фразу julia_abramova_
из ссылки https://www.instagram.com/julia_abramova_/ вытащить julia_abramova_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}