re = /\s(\S*)\sinstagram|www\.instagram\.com\/([^\/\s]*)\//m
str = 'Из текста Julia julia_abramova_ instagram нужно вытащить фразу julia_abramova_
из ссылки https://www.instagram.com/julia_abramova_/ вытащить julia_abramova_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end