$re = '/\s(\S*)\sinstagram|www\.instagram\.com\/([^\/\s]*)\//m';
$str = 'Из текста Julia julia_abramova_ instagram нужно вытащить фразу julia_abramova_
из ссылки https://www.instagram.com/julia_abramova_/ вытащить julia_abramova_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);