#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)'[^\\']*(?:\\.[^\\']*)*'|"[^\\"]*(?:\\.[^\\"]*)*""
Local $sString = "'foo bar baz' foo barbar baz "foo bar \"baz foo\" bar baz" foo bar 'foo \'bar bar\' baz' bar 'foo bar baz' foo barbar baz "foo bar \"baz foo\" bar baz" foo bar 'foo \'bar bar\' baz' bar 'foo bar baz' foo barbar baz "foo bar \"baz foo\" bar baz" foo bar 'foo \'bar bar\' baz' bar 'foo bar baz' foo barbar baz "foo bar \"baz foo\" bar baz" foo bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")