$re = '/\'[^\\\\\']*(?:\\\\.[^\\\\\']*)*\'|"[^\\\\"]*(?:\\\\.[^\\\\"]*)*"/m';
$str = '\'foo bar baz\' foo barbar baz "foo bar \\"baz foo\\" bar baz" foo bar \'foo \\\'bar bar\\\' baz\' bar \'foo bar baz\' foo barbar baz "foo bar \\"baz foo\\" bar baz" foo bar \'foo \\\'bar bar\\\' baz\' bar \'foo bar baz\' foo barbar baz "foo bar \\"baz foo\\" bar baz" foo bar \'foo \\\'bar bar\\\' baz\' bar \'foo bar baz\' foo barbar baz "foo bar \\"baz foo\\" bar baz" foo bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);