package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'[^\\']*(?:\\.[^\\']*)*'|"[^\\"]*(?:\\.[^\\"]*)*"`)
var str = `'foo bar baz' foo barbar baz "foo bar \"baz foo\" bar baz" foo bar 'foo \'bar bar\' baz' bar 'foo bar baz' foo barbar baz "foo bar \"baz foo\" bar baz" foo bar 'foo \'bar bar\' baz' bar 'foo bar baz' foo barbar baz "foo bar \"baz foo\" bar baz" foo bar 'foo \'bar bar\' baz' bar 'foo bar baz' foo barbar baz "foo bar \"baz foo\" bar baz" foo bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}