using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'([^\\']*(?:\\.[^\\']*)*)'|""([^\\""]*(?:\\.[^\\""]*)*)""";
string input = @"My text ""can contain"" both single 'and double""' quotes. The quotes ""can also be 'nested"" as you can see.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}