re = /'([^\\']*(?:\\.[^\\']*)*)'|"([^\\"]*(?:\\.[^\\"]*)*)"/m
str = 'My text "can contain" both single \'and double"\' quotes. The quotes "can also be \'nested" as you can see.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end