package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'([^\\']*(?:\\.[^\\']*)*)'|"([^\\"]*(?:\\.[^\\"]*)*)"`)
var str = `My text "can contain" both single 'and double"' quotes. The quotes "can also be 'nested" as you can see.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}