const regex = new RegExp('^
Student\\ number,\\ Name[\\n\\r]
(?P<student_names>(?:^\\d+.+[\\n\\r])+)
\\s*
^
Student\\ number,\\ Score[\\n\\r]
(?P<student_scores>(?:^\\d+.+[\\n\\r])+)', 'gm')
const str = `Grade = 1
Student number, Name
0, Phoebe
1, Rachel
Student number, Score
0, 3
1, 7
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}