#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\w*(\w)(\w)\2\1).*"
Local $sString = "acritan" & @CRLF & _
"aesthophysiology" & @CRLF & _
"amphimictical" & @CRLF & _
"baruria" & @CRLF & _
"calomorphic" & @CRLF & _
"disarmature" & @CRLF & _
"effusive" & @CRLF & _
"fluted" & @CRLF & _
"fusoid" & @CRLF & _
"goblinize" & @CRLF & _
"nihilistic" & @CRLF & _
"noisefully" & @CRLF & _
"picrorhiza" & @CRLF & _
"postarytenoid" & @CRLF & _
"revolutionize" & @CRLF & _
"suprasphanoidal" & @CRLF & _
"suspenseful" & @CRLF & _
"tapachula" & @CRLF & _
"transmit" & @CRLF & _
"unversatile" & @CRLF & _
"vibetoite" & @CRLF & _
"" & @CRLF & _
"abba" & @CRLF & _
"anallagmatic" & @CRLF & _
"bassarisk" & @CRLF & _
"chorioallantois" & @CRLF & _
"coccomyces" & @CRLF & _
"commotive" & @CRLF & _
"engrammatic" & @CRLF & _
"glossoscopia" & @CRLF & _
"hexacoralla" & @CRLF & _
"hippogriffin" & @CRLF & _
"inflammableness" & @CRLF & _
"otto" & @CRLF & _
"overattached" & @CRLF & _
"saffarid" & @CRLF & _
"sarraceniaceae" & @CRLF & _
"scillipicrin" & @CRLF & _
"tlapallan" & @CRLF & _
"trillion" & @CRLF & _
"unclassably" & @CRLF & _
"unfitting" & @CRLF & _
"unsmelled" & @CRLF & _
"warrandice"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")