# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!\w*(\w)(\w)\2\1).*"
test_str = ("acritan\n"
"aesthophysiology\n"
"amphimictical\n"
"baruria\n"
"calomorphic\n"
"disarmature\n"
"effusive\n"
"fluted\n"
"fusoid\n"
"goblinize\n"
"nihilistic\n"
"noisefully\n"
"picrorhiza\n"
"postarytenoid\n"
"revolutionize\n"
"suprasphanoidal\n"
"suspenseful\n"
"tapachula\n"
"transmit\n"
"unversatile\n"
"vibetoite\n\n"
"abba\n"
"anallagmatic\n"
"bassarisk\n"
"chorioallantois\n"
"coccomyces\n"
"commotive\n"
"engrammatic\n"
"glossoscopia\n"
"hexacoralla\n"
"hippogriffin\n"
"inflammableness\n"
"otto\n"
"overattached\n"
"saffarid\n"
"sarraceniaceae\n"
"scillipicrin\n"
"tlapallan\n"
"trillion\n"
"unclassably\n"
"unfitting\n"
"unsmelled\n"
"warrandice")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.