import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\w*(\\w)(\\w)\\2\\1).*";
final String string = "acritan\n"
+ "aesthophysiology\n"
+ "amphimictical\n"
+ "baruria\n"
+ "calomorphic\n"
+ "disarmature\n"
+ "effusive\n"
+ "fluted\n"
+ "fusoid\n"
+ "goblinize\n"
+ "nihilistic\n"
+ "noisefully\n"
+ "picrorhiza\n"
+ "postarytenoid\n"
+ "revolutionize\n"
+ "suprasphanoidal\n"
+ "suspenseful\n"
+ "tapachula\n"
+ "transmit\n"
+ "unversatile\n"
+ "vibetoite\n\n"
+ "abba\n"
+ "anallagmatic\n"
+ "bassarisk\n"
+ "chorioallantois\n"
+ "coccomyces\n"
+ "commotive\n"
+ "engrammatic\n"
+ "glossoscopia\n"
+ "hexacoralla\n"
+ "hippogriffin\n"
+ "inflammableness\n"
+ "otto\n"
+ "overattached\n"
+ "saffarid\n"
+ "sarraceniaceae\n"
+ "scillipicrin\n"
+ "tlapallan\n"
+ "trillion\n"
+ "unclassably\n"
+ "unfitting\n"
+ "unsmelled\n"
+ "warrandice";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}