const regex = /# Use a bunch of lookaheads
(?=
\S*time=(?<time>[^\s=&]*)
)
(?=
\S*user=(?<name>[^\s=&]*)
)
(?=
\S*sport=(?<sport>[^\s=&]*)
)
\S+?
\&something/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('# Use a bunch of lookaheads
(?=
\\S*time=(?<time>[^\\s=&]*)
)
(?=
\\S*user=(?<name>[^\\s=&]*)
)
(?=
\\S*sport=(?<sport>[^\\s=&]*)
)
\\S+?
\\&something', 'g')
const str = `Log 1: user=mike&time=now&sport=hockey&something
Log 2: time=now&sport=hockey&user=mike&something
Log 3: sport=hockey&time=now&user=mike&something`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}