$re = '/# Use a bunch of lookaheads
(?=
\S*time=(?<time>[^\s=&]*)
)
(?=
\S*user=(?<name>[^\s=&]*)
)
(?=
\S*sport=(?<sport>[^\s=&]*)
)
\S+?
\&something/x';
$str = 'Log 1: user=mike&time=now&sport=hockey&something
Log 2: time=now&sport=hockey&user=mike&something
Log 3: sport=hockey&time=now&user=mike&something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);