// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)# Use a bunch of lookaheads
(?=
\S*time=(?<time>[^\s=&]*)
)
(?=
\S*user=(?<name>[^\s=&]*)
)
(?=
\S*sport=(?<sport>[^\s=&]*)
)
\S+?
\&something").unwrap();
let string = "Log 1: user=mike&time=now&sport=hockey&something
Log 2: time=now&sport=hockey&user=mike&something
Log 3: sport=hockey&time=now&user=mike&something";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}