#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bhttp:\/\/www\.website\.com\/(?:(?!b=[0-9]+).)*?\b(?= |$)"
Local $sString = "http://www.website.com/a=789&c=146&b=557" & @CRLF & _
"http://www.website.com/a=789&c=146&b=557" & @CRLF & _
"http://www.website.com/b=412&c=146&a=874" & @CRLF & _
"http://www.website.com/c=146&a=8b7 fail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")