$re = '/\bhttp:\/\/www\.website\.com\/(?:(?!b=[0-9]+).)*?\b(?= |$)/m';
$str = 'http://www.website.com/a=789&c=146&b=557
http://www.website.com/a=789&c=146&b=557
http://www.website.com/b=412&c=146&a=874
http://www.website.com/c=146&a=8b7 fail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);