re = /\bhttp:\/\/www\.website\.com\/(?:(?!b=[0-9]+).)*?\b(?= |$)/m
str = 'http://www.website.com/a=789&c=146&b=557
http://www.website.com/a=789&c=146&b=557
http://www.website.com/b=412&c=146&a=874
http://www.website.com/c=146&a=8b7 fail'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end