#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)r?call[\t ]+_(?!.*boot).*"
Local $sString = " 88811 000294 00 A0 A9 bclr.b _RCONbits,#5 ;," & @CRLF & _
" 88813 000296 00 00 07 call _vBootInitSerialBuffer ;" & @CRLF & _
" 88815 000298 F0 0E 20 mov #239,w0 ;," & @CRLF & _
" 88816 00029a 00 00 07 rcall _vBootInitSerial_C1 ;" & @CRLF & _
" 88818 00029c F0 0E 20 mov #239,w0 ;," & @CRLF & _
" 88819 00029e 00 00 07 rcall _vBootInitSerial_C2 ;" & @CRLF & _
" 88821 0002a0 00 40 EB clr.b w0 ; tmp38" & @CRLF & _
" 88822 0002a2 00 E0 B7 mov.b WREG,_gbTurnOnLED ; gbTurnOnLED" & @CRLF & _
" 89049 00032e E0 0F 50 sub w0,#0,[w15] ; tmp56," & @CRLF & _
" 89050 Call the routine" & @CRLF & _
" 89051 000330 00 00 3A bra nz,.L50 ;" & @CRLF & _
" 89053 000332 10 C0 B3 mov.b #1,w0 ;," & @CRLF & _
" 89054 000334 00 00 07 rcall _memcpy ; <HIT>" & @CRLF & _
" 89055 000336 00 00 37 bra .L50 ;" & @CRLF & _
" 89054 000334 00 00 07 rcall _BxootGGashLED ; <HIT>" & @CRLF & _
" 89055 000336 00 00 37 bra .L50 ;" & @CRLF & _
" 89054 000334 00 00 07 rcall _BootFlashLED ;" & @CRLF & _
" 89054 000334 00 00 07 call _ln ; <HIT>" & @CRLF & _
" 89055 000336 00 00 37 bra .L50 ;" & @CRLF & _
" 89054 000334 00 00 07 call _vBoootFlashLED ; <HIT>" & @CRLF & _
" 89055 000336 00 00 37 bra .L50 ;" & @CRLF & _
" 89054 000334 00 00 07 rcall _u8BootGGashLED ;" & @CRLF & _
" 89055 000336 00 00 37 bra .L50 ;" & @CRLF & _
" 89054 000334 00 00 07 rcall _u16bootGGashLED ;" & @CRLF & _
" 89055 000336 00 00 37 bra .L50 ;" & @CRLF & _
" 89056 .L49:" & @CRLF & _
" 89058 000338 00 00 80 mov _gu16_50HzTimerTick,w0 ;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")