import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "r?call[\\t ]+_(?!.*boot).*";
final String string = " 88811 000294 00 A0 A9 bclr.b _RCONbits,#5 ;,\n"
+ " 88813 000296 00 00 07 call _vBootInitSerialBuffer ;\n"
+ " 88815 000298 F0 0E 20 mov #239,w0 ;,\n"
+ " 88816 00029a 00 00 07 rcall _vBootInitSerial_C1 ;\n"
+ " 88818 00029c F0 0E 20 mov #239,w0 ;,\n"
+ " 88819 00029e 00 00 07 rcall _vBootInitSerial_C2 ;\n"
+ " 88821 0002a0 00 40 EB clr.b w0 ; tmp38\n"
+ " 88822 0002a2 00 E0 B7 mov.b WREG,_gbTurnOnLED ; gbTurnOnLED\n"
+ " 89049 00032e E0 0F 50 sub w0,#0,[w15] ; tmp56,\n"
+ " 89050 Call the routine\n"
+ " 89051 000330 00 00 3A bra nz,.L50 ;\n"
+ " 89053 000332 10 C0 B3 mov.b #1,w0 ;,\n"
+ " 89054 000334 00 00 07 rcall _memcpy ; <HIT>\n"
+ " 89055 000336 00 00 37 bra .L50 ;\n"
+ " 89054 000334 00 00 07 rcall _BxootGGashLED ; <HIT>\n"
+ " 89055 000336 00 00 37 bra .L50 ;\n"
+ " 89054 000334 00 00 07 rcall _BootFlashLED ;\n"
+ " 89054 000334 00 00 07 call _ln ; <HIT>\n"
+ " 89055 000336 00 00 37 bra .L50 ;\n"
+ " 89054 000334 00 00 07 call _vBoootFlashLED ; <HIT>\n"
+ " 89055 000336 00 00 37 bra .L50 ;\n"
+ " 89054 000334 00 00 07 rcall _u8BootGGashLED ;\n"
+ " 89055 000336 00 00 37 bra .L50 ;\n"
+ " 89054 000334 00 00 07 rcall _u16bootGGashLED ;\n"
+ " 89055 000336 00 00 37 bra .L50 ;\n"
+ " 89056 .L49:\n"
+ " 89058 000338 00 00 80 mov _gu16_50HzTimerTick,w0 ;";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}