# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"r?call[\t ]+_(?!.*boot).*"
test_str = (" 88811 000294 00 A0 A9 bclr.b _RCONbits,#5 ;,\n"
" 88813 000296 00 00 07 call _vBootInitSerialBuffer ;\n"
" 88815 000298 F0 0E 20 mov #239,w0 ;,\n"
" 88816 00029a 00 00 07 rcall _vBootInitSerial_C1 ;\n"
" 88818 00029c F0 0E 20 mov #239,w0 ;,\n"
" 88819 00029e 00 00 07 rcall _vBootInitSerial_C2 ;\n"
" 88821 0002a0 00 40 EB clr.b w0 ; tmp38\n"
" 88822 0002a2 00 E0 B7 mov.b WREG,_gbTurnOnLED ; gbTurnOnLED\n"
" 89049 00032e E0 0F 50 sub w0,#0,[w15] ; tmp56,\n"
" 89050 Call the routine\n"
" 89051 000330 00 00 3A bra nz,.L50 ;\n"
" 89053 000332 10 C0 B3 mov.b #1,w0 ;,\n"
" 89054 000334 00 00 07 rcall _memcpy ; <HIT>\n"
" 89055 000336 00 00 37 bra .L50 ;\n"
" 89054 000334 00 00 07 rcall _BxootGGashLED ; <HIT>\n"
" 89055 000336 00 00 37 bra .L50 ;\n"
" 89054 000334 00 00 07 rcall _BootFlashLED ;\n"
" 89054 000334 00 00 07 call _ln ; <HIT>\n"
" 89055 000336 00 00 37 bra .L50 ;\n"
" 89054 000334 00 00 07 call _vBoootFlashLED ; <HIT>\n"
" 89055 000336 00 00 37 bra .L50 ;\n"
" 89054 000334 00 00 07 rcall _u8BootGGashLED ;\n"
" 89055 000336 00 00 37 bra .L50 ;\n"
" 89054 000334 00 00 07 rcall _u16bootGGashLED ;\n"
" 89055 000336 00 00 37 bra .L50 ;\n"
" 89056 .L49:\n"
" 89058 000338 00 00 80 mov _gu16_50HzTimerTick,w0 ;")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.