#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^[\#]$"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# Hello 54.217.223.119. Your session has been logged.<br />" & @CRLF & _
"#<br />" & @CRLF & _
"# Copyright (c) 2002 - 2014 by DK Hostmaster A/S<br />" & @CRLF & _
"# <br />" & @CRLF & _
"# The data in the DK Whois database is provided by DK Hostmaster A/S<br />" & @CRLF & _
"# for information purposes only, and to assist persons in obtaining<br />" & @CRLF & _
"# information about or related to a domain name registration record.<br />" & @CRLF & _
"# We do not guarantee its accuracy. We will reserve the right to remove<br />" & @CRLF & _
"# access for entities abusing the data, without notice.<br />" & @CRLF & _
"# <br />" & @CRLF & _
"# Any use of this material to target advertising or similar activities<br />" & @CRLF & _
"# are explicitly forbidden and will be prosecuted. DK Hostmaster A/S<br />" & @CRLF & _
"# requests to be notified of any such activities or suspicions thereof.<br />" & @CRLF & _
"Domain: dr.dk<br />" & @CRLF & _
"DNS: dr.dk<br />" & @CRLF & _
"Registered: 1998-03-11<br />" & @CRLF & _
"Expires: 2015-03-31<br />" & @CRLF & _
"Registration period: 1 year<br />" & @CRLF & _
"VID: no<br />" & @CRLF & _
"Status: Active<br />" & @CRLF & _
"Registrant<br />" & @CRLF & _
"Handle: D5109-DK<br />" & @CRLF & _
"Name: DR<br />" & @CRLF & _
"Address: DR-Byen, Emil Holms kanal 20<br />" & @CRLF & _
"Postalcode: 0999<br />" & @CRLF & _
"City: København C<br />" & @CRLF & _
"Country: DK<br />" & @CRLF & _
"Phone: +4535203661<br />" & @CRLF & _
"Administrator<br />" & @CRLF & _
"Handle: DH4991-DK<br />" & @CRLF & _
"Name: DR<br />" & @CRLF & _
"Attention: DR Hostmaster<br />" & @CRLF & _
"Address: DR-Byen, Emil Holms kanal 20<br />" & @CRLF & _
"Postalcode: 0999<br />" & @CRLF & _
"City: København C<br />" & @CRLF & _
"Country: DK<br />" & @CRLF & _
"Phone: +4535203660<br />" & @CRLF & _
"Nameservers<br />" & @CRLF & _
"Hostname: dns101.telia.com<br />" & @CRLF & _
"Handle: TA632-DK<br />" & @CRLF & _
"Hostname: dns102.telia.com<br />" & @CRLF & _
"Handle: TA632-DK<br />" & @CRLF & _
"Hostname: ns01.dr.dk<br />" & @CRLF & _
"Handle: DR3450-DK<br />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")