# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\#]$"
test_str = ("\n\n\n\n\n\n"
"# Hello 54.217.223.119. Your session has been logged.<br />\n"
"#<br />\n"
"# Copyright (c) 2002 - 2014 by DK Hostmaster A/S<br />\n"
"# <br />\n"
"# The data in the DK Whois database is provided by DK Hostmaster A/S<br />\n"
"# for information purposes only, and to assist persons in obtaining<br />\n"
"# information about or related to a domain name registration record.<br />\n"
"# We do not guarantee its accuracy. We will reserve the right to remove<br />\n"
"# access for entities abusing the data, without notice.<br />\n"
"# <br />\n"
"# Any use of this material to target advertising or similar activities<br />\n"
"# are explicitly forbidden and will be prosecuted. DK Hostmaster A/S<br />\n"
"# requests to be notified of any such activities or suspicions thereof.<br />\n"
"Domain: dr.dk<br />\n"
"DNS: dr.dk<br />\n"
"Registered: 1998-03-11<br />\n"
"Expires: 2015-03-31<br />\n"
"Registration period: 1 year<br />\n"
"VID: no<br />\n"
"Status: Active<br />\n"
"Registrant<br />\n"
"Handle: D5109-DK<br />\n"
"Name: DR<br />\n"
"Address: DR-Byen, Emil Holms kanal 20<br />\n"
"Postalcode: 0999<br />\n"
"City: København C<br />\n"
"Country: DK<br />\n"
"Phone: +4535203661<br />\n"
"Administrator<br />\n"
"Handle: DH4991-DK<br />\n"
"Name: DR<br />\n"
"Attention: DR Hostmaster<br />\n"
"Address: DR-Byen, Emil Holms kanal 20<br />\n"
"Postalcode: 0999<br />\n"
"City: København C<br />\n"
"Country: DK<br />\n"
"Phone: +4535203660<br />\n"
"Nameservers<br />\n"
"Hostname: dns101.telia.com<br />\n"
"Handle: TA632-DK<br />\n"
"Hostname: dns102.telia.com<br />\n"
"Handle: TA632-DK<br />\n"
"Hostname: ns01.dr.dk<br />\n"
"Handle: DR3450-DK<br />")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.