import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\#]$";
final String string = "\n\n\n\n\n\n"
+ "# Hello 54.217.223.119. Your session has been logged.<br />\n"
+ "#<br />\n"
+ "# Copyright (c) 2002 - 2014 by DK Hostmaster A/S<br />\n"
+ "# <br />\n"
+ "# The data in the DK Whois database is provided by DK Hostmaster A/S<br />\n"
+ "# for information purposes only, and to assist persons in obtaining<br />\n"
+ "# information about or related to a domain name registration record.<br />\n"
+ "# We do not guarantee its accuracy. We will reserve the right to remove<br />\n"
+ "# access for entities abusing the data, without notice.<br />\n"
+ "# <br />\n"
+ "# Any use of this material to target advertising or similar activities<br />\n"
+ "# are explicitly forbidden and will be prosecuted. DK Hostmaster A/S<br />\n"
+ "# requests to be notified of any such activities or suspicions thereof.<br />\n"
+ "Domain: dr.dk<br />\n"
+ "DNS: dr.dk<br />\n"
+ "Registered: 1998-03-11<br />\n"
+ "Expires: 2015-03-31<br />\n"
+ "Registration period: 1 year<br />\n"
+ "VID: no<br />\n"
+ "Status: Active<br />\n"
+ "Registrant<br />\n"
+ "Handle: D5109-DK<br />\n"
+ "Name: DR<br />\n"
+ "Address: DR-Byen, Emil Holms kanal 20<br />\n"
+ "Postalcode: 0999<br />\n"
+ "City: København C<br />\n"
+ "Country: DK<br />\n"
+ "Phone: +4535203661<br />\n"
+ "Administrator<br />\n"
+ "Handle: DH4991-DK<br />\n"
+ "Name: DR<br />\n"
+ "Attention: DR Hostmaster<br />\n"
+ "Address: DR-Byen, Emil Holms kanal 20<br />\n"
+ "Postalcode: 0999<br />\n"
+ "City: København C<br />\n"
+ "Country: DK<br />\n"
+ "Phone: +4535203660<br />\n"
+ "Nameservers<br />\n"
+ "Hostname: dns101.telia.com<br />\n"
+ "Handle: TA632-DK<br />\n"
+ "Hostname: dns102.telia.com<br />\n"
+ "Handle: TA632-DK<br />\n"
+ "Hostname: ns01.dr.dk<br />\n"
+ "Handle: DR3450-DK<br />";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}