import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*\\b(?:(?:Pvt|Ltd|Pte|Co)\\.?|Inc\\.|Incorporated|Private Limited))+";
final String string = "0.5Bn FinHealth Pvt. Ltd.Inc. Pte.Co.Private Limited Incorporated,\n"
+ "0.5Bn FinHealth Ltd.,\n"
+ "1MG Technologies Pvt. Ltd.,";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}