const regex = /(?:\s*\b(?:(?:Pvt|Ltd|Pte|Co)\.?|Inc\.|Incorporated|Private Limited))+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*\\b(?:(?:Pvt|Ltd|Pte|Co)\\.?|Inc\\.|Incorporated|Private Limited))+', 'gm')
const str = `0.5Bn FinHealth Pvt. Ltd.Inc. Pte.Co.Private Limited Incorporated,
0.5Bn FinHealth Ltd.,
1MG Technologies Pvt. Ltd.,`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);