$re = '/(?:\s*\b(?:(?:Pvt|Ltd|Pte|Co)\.?|Inc\.|Incorporated|Private Limited))+/m';
$str = '0.5Bn FinHealth Pvt. Ltd.Inc. Pte.Co.Private Limited Incorporated,
0.5Bn FinHealth Ltd.,
1MG Technologies Pvt. Ltd.,';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;