using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(\.[^\.\(]*)\1\(.*";
string input = @"ns1.Class1.Class1()
ns1.Class1.Print(
ns2.Class2.Class2()";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}