$re = '/.*(\.[^\.\(]*)\1\(.*/';
$str = 'ns1.Class1.Class1()
ns1.Class1.Print(
ns2.Class2.Class2()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);