import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+([\\w\\-]+)\\s+([\\w\\-]+)\\s+(\\w+)\\s+(\\d+)\\s+";
final String string = "####################################################################################\n"
+ "# <IP-Address> <ServiceType> <ServiceName> <MaxMemory> <Port>\n"
+ "####################################################################################\n"
+ "#192.168.122.225 database database 1024M \n"
+ "#192.168.122.226 database database 1024M \n"
+ "192.168.122.253 database database 1024M\n"
+ "## MCng BackEnd ServicesG\n"
+ "#192.168.122.125 amqs activemq 1024M\n"
+ "#\n"
+ "# <IP-Address> <ServiceType> <ServiceName> <MaxMemory> <JMXPort> <WebPort> #\n"
+ " \n\n"
+ "#\n"
+ "192.168.122.125 csm csm 2048M 12000\n"
+ "192.168.122.125 clog clog 1024M 12001\n"
+ "192.168.122.146 sec \n"
+ "192.168.122.105 dtu-ds dtu-ds01 4096M 12004 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}