import re
regex = re.compile(r"(\d+\.\d+\.\d+\.\d+)\s+([\w\-]+)\s+([\w\-]+)\s+(\w+)\s+(\d+)\s+")
test_str = ("####################################################################################\n"
"# <IP-Address> <ServiceType> <ServiceName> <MaxMemory> <Port>\n"
"####################################################################################\n"
"#192.168.122.225 database database 1024M \n"
"#192.168.122.226 database database 1024M \n"
"192.168.122.253 database database 1024M\n"
"## MCng BackEnd ServicesG\n"
"#192.168.122.125 amqs activemq 1024M\n"
"#\n"
"# <IP-Address> <ServiceType> <ServiceName> <MaxMemory> <JMXPort> <WebPort> #\n"
" \n\n"
"#\n"
"192.168.122.125 csm csm 2048M 12000\n"
"192.168.122.125 clog clog 1024M 12001\n"
"192.168.122.146 sec \n"
"192.168.122.105 dtu-ds dtu-ds01 4096M 12004 ")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")