// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+\.\d+\.\d+\.\d+)\s+([\w\-]+)\s+([\w\-]+)\s+(\w+)\s+(\d+)\s+").unwrap();
let string = "####################################################################################
# <IP-Address> <ServiceType> <ServiceName> <MaxMemory> <Port>
####################################################################################
#192.168.122.225 database database 1024M
#192.168.122.226 database database 1024M
192.168.122.253 database database 1024M
## MCng BackEnd ServicesG
#192.168.122.125 amqs activemq 1024M
#
# <IP-Address> <ServiceType> <ServiceName> <MaxMemory> <JMXPort> <WebPort> #
#
192.168.122.125 csm csm 2048M 12000
192.168.122.125 clog clog 1024M 12001
192.168.122.146 sec
192.168.122.105 dtu-ds dtu-ds01 4096M 12004 ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}