import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<first>Transaction ID: (?<transId>\\w{1,})\\.)(.*)(?<second>Reference code: (?<refCode>\\w{1,})\\.)";
final String string = "Your transaction was successful. Transaction ID: 453712046. Reference code: 1234326. Thank you!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}