const regex = /(?<first>Transaction ID: (?<transId>\w{1,})\.)(.*)(?<second>Reference code: (?<refCode>\w{1,})\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<first>Transaction ID: (?<transId>\\w{1,})\\.)(.*)(?<second>Reference code: (?<refCode>\\w{1,})\\.)', 'gm')
const str = `Your transaction was successful. Transaction ID: 453712046. Reference code: 1234326. Thank you!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}